Cannot set Language permalinks

Home Forums WordPress Plugins Language Switcher Cannot set Language permalinks

Viewing 2 reply threads
  • Author
    Posts
    • #8094
      martinson74
      Participant

      Hi, I was working on a site that I inherited that has this plugin installed and working like a charm.
      I added another language perfectly, generated the new posts and set its correspondinnpermalinks for the other languages.
      It worked perfectly, but suddenly we realized that changing language from the menu takes us to the language home page.
      Also, if I set the links, update the post, go back to posts and edit again, there are no links. So it’s no saving.
      In a desperate attempt to see what was happening y browse wp_postmeta table and y can see link there.
      I tryed desabling and re-enabling the plugin, with no luck.

      Version of WordPress is 5.9.2_es-ES
      Version of Language Switcher is 3.2.10

      Can you please give me a hint of what could be going on?

      Thanks in advance

      Martín

    • #8101
      Rafasashi
      Keymaster

      Hello Martin,

      Thank you for reporting this.

      The issue was fixed in the version 3.5.0

      Could you please try and let me know if it works for you?

    • #8102
      martinson74
      Participant

      Thank you for your answer.
      I did test this version and could update the links.
      I could not retrieve the links that were already set, but, I think is close enough.

      Many thanks again for your answer, and for working on it.

      Martín

Viewing 2 reply threads
  • You must be logged in to reply to this topic.